Georeference pdf command not working TBC v5.70.1

Hello everyone!

Me and my colleague just installed the latest version of TBC (v5.70.1) but now we can not seem to georeference PDFs, the compute button in the command is greyed out. Are we missing something like in the options or could this be a bug?
Anyone having och had the same issue?
Thankful for any tips.

Same issue here.

Import the PDF close the import window and run the Georeference Image command, select the PDF you want to ref and go from there. Its slightly different than the Import-Geo Ref work flow but it works.

Hopefully that helps.

Yes tried that and that works but then it seems like the Georeference pdf command is broken/doesn’t work. Needs to be fixed.

Is it a Vector PDF - if not it wont work


Yes they are all vector based pdfs. I’ve even tried with files that I have already georeferenced in previous projects that worked upuntil I updated to v5.70.1.
Has the workflow changed in this version or something in the settings?

Check out the picture

I will take a look - the last one u did was. Raster pdf so I did not use that function but I am sure I have done Vector PDFs since 7.1 came out


Great thanks! Like I said before me and my collegue have had the same issue since installing v.5.70.1

Did you do an uninstall of TBC before updating to 5.70.1? I feel like I had some issues before doing this.

No I haven’t just did the install. So what are your tips Pat? What where the steps you took? Some guidance please.

No real tips, there were several components of TBC that seemed to be running oddly for me that I couldn’t explain.

I don’t necessarily use the TBC cleanup every time, because of everything it wipes out, but I have got in the habit of doing an uninstall before installing new versions of TBC. Seems to work a little smoother.

I always do the following

  1. I move the prior installation by Cutting and Pasting the Trimble Business center Folder from the \Program Files\Trimble\Trimble Business Center location on your computer to my TBC Versions Folder in My Documents - That way I can still use the old version any time I want to.

  2. Then I run Control Panel and Uninstall a Program, Select Trimble Business Center from the programs and let it do its thing

  3. Then I have the Downloaded Offline Version of the TBC Installer - I never use the Online Installer because I always want the Installation Package for future use - and I have had more success with Offline Package than Online Package. I install from there.

Then I restart and work with TBC, Reset my Rockpile Menus and I am good to roll


1 Like

Thanks for your tips @Plheureux and I’ll try them this weekend.

Cheers mates!!

Tried this and installed TBC v5.81 but with no progress.

Can you share the PDF - need to check that it is a Vector PDF not a Raster - and also to see if this is one of those Swedish Comma vs decimal point issues - I can try to load it on my side - I was using 5.81 in training yesterday and we were Georeferencing files OK in the training with 5.81 so it is working for me.

If the file is not a Vector then it probably wont let you complete as there are No Vector Snaps to extract


300T025A_revA.pdf (871.4 KB)

It is a vector pdf because I’ve used it in previous versions of TBC, it was from v5.70 this command didn’t work for me and my companion anymore. The Georeference image works though and from there I’m able to import the vectors.
I’ve talked to @Fredrik_Bergstrom yesterday and he and his staff doesn’t have this issue. He gave some tips to try but none did work. The strange thing is that it is me and my companion that has this issue and we was starting to think if it’s something to do with our license??
We have a enterprise license and a site&field license.

I’ve had this issue before. Are you using your own template? Try using a default if not and georeferencing it.

Yes I usually use my own template but tried using a blank template also but that didn’t work either. Seems like it’s this one and only command that the compute/execute button is greyed out for us. Tried also closing the property pane, view filter and selection set panes to have as little as possible open but no success there either.

Joseph, I was able to Georeference the PDF with no issues using the standard metric template. If you get a chance, shoot me the project you are trying to bring this into and I’ll take a look at it.

Yes @Chris_Bayliff I knew that it would work for you it did for me as well until the update to v5.70 where this new tick box for save snap locations was introduced. After that me and my colleague (same company) couldn’t execute the command anymore, the register button in the command is greyed out as you can see in my picture in previous posts.
Here in Sweden I would say 99% of all PDFs from designers are vector based so I have tried different pdf sources with the same results. I chose this pdf because I know it works because I’m using it in a project right now that’s been running since 2021 and still going.
Would be nice to get the command to work because there are some revisions coming up and I would probably need to scrap some of my already georeferenced PDFs with the revised ones. For now I’m using the Georeference image command to get PDFs into my TBC projects, that command works for us but we miss out on the capabilities of using snaps on the PDFs which is real drag.
Thanks for everyone chipping in here with tips on this issue of ours.

Can you check to see if before you run the command if Vector Point Snap is turned On or Off in running snaps - maybe if it is Off when you run the command maybe it trips something up in the command

Could also be something to do with Path name length - if you are storing projects in my documents folders then you may be exceeding windows path length limits - try moving your project to storage to C drive root so there is no base pathe name length.

Could it also be something to do with One Drive - make sure that syncing of One Drive is off before you start TBC or trying to do this- it could also be something to do with that.?

If Fred is working OK in Sweden with the 5.81 version then it is not a Swedish Units / Comma issue - it must be a system issue on your computers / setup ,I would have thought - hard to tell where to look though

Just a few ideas of where I woukd start to look for the issue?