Linestring Editor VPI Glitch

I have noticed many times now I am getting a glitch or error when editing linestrings and adding VPI’s. I am unable to add a VPI elevation from snapping another elevation on some lines where I previously added a VPI. Such as from an end of the linestring. However if I snap the middle of a contour it will grab the elevation. This wasn’t present until U upgraded to 5.6 from 5.5.

The same error occurs when creating a linestring where it is no grabbing elevations from where I select.

(Edited: Also doing it on a line with a known elevation that i grabbed elevations from 3 other points on the line from but it wont grab the one point where the VPI is…)

Anyone else seeing this or do I have a setting wrong somewhere. All help appreciated.


I am using TBC v5.61 and I can snap to VPI points. The snap indicator never shows on VPI points - that has always been the case - and provided that you have End Point Snap turned on it should snap to the VPI even if it does not show you the snap indicator. I just created a linestring with 50 VPIs on it and then drew a second line to it and then along it snapping to each of the VPIs and it snapped perfectly to every VPI. I tried in both Plan and 3D view and it worked every time giving me the correct Z values in the new line.

Maybe there is something else going on here?

If you could send me the line you are trying to draw (make it red) and the source lines that you are snapping to (make them blue) in a VCL I can take a look for you to see if I can see what is going on and I can record you a video of what I am seeing.



I emailed you the information. Let me know I probably have something messed up in a setting somewhere that I can’t find.

thank you very much!!

Much of the running osnap functionality has been ruined by the 5.6.x upgrade.
Two off the top of my head:

1 Endpoint osnap won’t pick up an elevation from the endpoint of an existing line if there is a second unconnected line present even with the same elevation (i.e. curb corners). This was not the case in previous versions. I have picked up thousands of elevations from the endpoint osnap with multiple lines terminated at the same location with previous versions.

2 Moving/coping a line is now much more difficult as the running osnap prioritized the endpoint of the line being moved/copied making it very difficult to accurately move a line using the osnaps. How can you snap to a new location when its insisting on only snapping to the endpoint of the line being used. Then I challenge you to accurately copy/move a line to a new intersection location using right click snaps if there is no horizontal node there without jumping through a bunch of hoops. Previously I would depend on the surface vertex snap or near snap to copy/move a line to an existing VPI. But now, since it is insisting on endpoint snapping to the line that’s being moved, it doesn’t work. This same behavior is displayed when using the vertex stretch/move to edit the line as well.

Hopefully they will discover/verify/fix the issue soon as it very frustrating.

Edit: behavior described above is intermittent. Just did a stretch and it worked as expected. Yesterday it did not.

I found the issue that Dane was having was tied to the grabbing the end of line elevation did not work when there was a Georeferenced image visible behind the data. Turn that off everything worked correctly. I tried a mid line VPI snap and that seemed to work OK with the image behind the data.

As a work around the Right Click snaps like Along Line Snap or At Point snap worked OK - appreciate that is extra clicks etc. but at least it works and you don’t have to turn off the image.

I recorded a video and sent it to Trimble this am - hopefully they can address.

Richard - your issues sound similar but different - can you confirm if yours are also related to the Image On / Off as well or not so I can add to the fix request in with Trimble.


I have seen (1) in previous versions also - that is kind of dependent on where the pick cursor is over the two line endpoints - in some places it works and in others it doesn’t work - I think the issue here is if the cursor is more over the end of the 3D line it works, if it is more over the 2D line it fails - I also believe and have reported this many times, that the pick and snap cursors are not perfectly aligned - so when you center the cursor over the snap point, the snap point is slightly off - this can also compound the issue you are reporting. I think this one is and has been hit and miss for a while - for me if the snap finds more than one answer (undefined and a value) then the value would win every time. If it finds two possible answers (Value 1 and Value 2) then it should really tell you and ask which you want to use.

  1. You know that you can change the priority of object snapping right? Are you saying that that is not working - I am not 100% clear on the issue here - I just moved a line from its end point to an intersection of two lines where there was no end point OK - could you draw me a diagram of the issue here so I can try to recreate what you are saying. If you are not aware of the priority on snaps - in the snap selector you can increase or decrease the priority of the snaps that are running by moving them up and down in the list - the higher on the list of active snaps the higher the priiority - i.e. if you want Intersection above End Point - you can move Intersection higher in the list and then it will find an intersection over an end point snap - I have found some people that were not aware of that so could that be your issue here?

Let me know


It’s endpoint snapping to itself and won’t prioritize the surface vertex, no matter, even though it prioritized as #1


Image off seems to work (grabs endpoint elev)

Image on - does not work

Jumping back on this here. I am still having the same issues Alan even with the PDF in the background turned off. This is on multiple projects. I will save this file at the point I am at and maybe we can do a screen share this week so I can show you exactly the issues that are coming up and you can pass to Trimble with this.

Or something like that…

Let me know whenever you get around to reading this.

Thanks. I will continue to work around for now.

1 Like

I have seen some snap issues also Dane - I will try to find out where Trimble thinks they are on this currently.


1 Like