Matrix Copy Command Issue

Not sure if the command is malfunctioning or I’m having a major brain fart and botching an otherwise seemingly straight forward command. (I stopped and updated the command upon the initial click when the noticed popped up)

Tried a whole bunch of different methods of entry and snapping methods all resulting in unexpected outcomes. I’m simply trying to do a single row, 52 column array of a 10’ linestring (highlighted), spaced 12’ apart, along a curb alignment that has an azimuth 88d51’06". As you see in the clip that’s exactly what’s entered. I tried the From and To point as the same point and the From and To point at the bearing and distance apart mentioned above.

The initial results were the 52 linestrings were produced with 0’ horiz column offset but with vertical differences of billions of feet between each one. Locked up the 3d view tight. I removed the command, restarted TBC, re-added the command and restarted TBC again. Now the command is arraying one end of the linestring but not the other and is elevating the arrayed end by billions of feet (see the clip).

As I need this out now, I am going to make the array manually, however, please advise on what I am doing incorrectly or provide an updated command. Thanks.

1 Like

It’s actually quadrillions of feet but who’s counting bogus numbers? :rofl: :rofl: :rofl: :rofl:

The issue is your Vertical Angle (and us setting a stupid default) - the Vertical Angle by default should be H0 or Z90 not Z0 which is vertical - so a 12 foot spacing horizontally on a vertical angle of 0 is a long way as you have found - I will get the default set to H0 or Z90 so that the columns are Horizontal by default.



D’oh… I knew it was probably something silly. I looked at those fields and they checked for some reason… like I said… brain fart.

This is fixed now and all working well

Thanks for letting me know Richard


1 Like