TBC Crash Issues

I am having trouble pulling in 2 files that have been sent to me. They are both DWG’s one is 16mb the other is 6mb. I have sent them to my Sitech TBC guy and he has no problem. He also tried to just send me the linework that I was looking for via a DXF. When I pull them in program says importing and then crashes and disappears off the screen with no warning. Running TBC V5.30

Are you limited to v5.3 because of your warranty is no longer valid / expired etc.

I cannot recall an issue that caused dxf / dwg crashes back then but for sure your TBC is aging and the newer versions have had many improvements to DWG and DXF support - I am not sure if I have a TBC 5.3x install on my computer I can take a look if you want to share the file - it could be that the versions of the DWG are newer than the TBC version can handle

This is one of the “unknown” benefits of keeping your TBC up to date - AutoCAD and Bentley move on each year - the library that TBC uses to decode and write DWG / DXF and DGN files also moves on each year in line with the Autodesk and Bentley changes and that is incorporated in each release of TBC to mitigate these types of incompatibility issue - reading the latest DWGs in an older version of TBC is going to fail sooner or later because of file content changes that are unsupported

There are patch versions for 5.30 up to 5.30.3 so maybe get the latest patch version or if your warranty date allows try going to 5.40.2 (I think)

If there is something corrupted on your install a re install may help you and then try again.

Not sure what else I can suggest here - you will likely be told by SITECH and Trimble that later versions of TBC work and that you will need to upgrade your version - for sure Trimble likely won’t go back to 5.30 and make a patch for that version which must be 3 to 4 years out of date now.

Someone can likely read the files and write them out for you in a format readable by TBC v5.30 for a fee - we could potentially do that - I would.likely have to install v5.30 which would take me some time so I could check the output for you to make sure it worked.


Thank you, Alan, for your quick response I will update and see if the issue continues.