Trim by Slope Distance

I am trying to find a faster solution to trimming a linestring by slope distance. I have a riprap under a bridge where I am needing to measure up 15’ from the bottom of the riprap and add a linestring. There is the trim by station method which I would use if there is not another method. I forgot the using station will not work as that is a 2d method .

Divide by Slope Distance Command will do that and create points 15’ up a 3D line or you can just use the Right Click COGO Snaps but those dont work on 3D only really in 2D - so Divide by Slope Distance would be my Go To command for that - in the RPS Data Prep Menu


That tool will not let me run the configure option. message that came up.

Run TMLStatus and update that command that should get it setup right. Then restart TBC for the update to take effect


It sounds like you may need to update your TML System - I would download and Install the latest TMLStatus from the website and then start TBC and then run TMLStatus and update all of your TMLs and then restart TBC - that should fix any issues - call me if you need help doing that (+1 720 323 0481)


Downloaded TML Status from website and then updated all TMLs. also updated to v5.4. ( i never was one to jump on the newest releases) Still receiving same error.

We will call you nest week to resolve Frank

Can you go to your Macros Installation folder at C:\ProgramData\Trimble\MacroCommands\Trimble

In that folder look for the following


Find any of these files and then delete them

Restart TBC

Re Run TMLStatus and find that command in the list and reinstall it

Restart TBC

Try the command again and let me know if it works now. I think this should fix the issue that you are seeing.

If not I will call you Monday

First place I looked. I didn’t see any when I looked yesterday, only seen it in the RPS folder. I’ll double check later today.

update. maybe i did not squint my eyes hard enough. there was a file for that command. Only the pydll file extension is there. Still no luck, even went to TML status and did remove from the list and did restart on TBC. no go

In the folder that I told you to look at earlier can you go up one level and tell me what folders are there - should be a Trimble Folder and a Rockpile Folder - are there any others - if yes can you look in that folder and see what is there.

I think when I did the training in Texas 18 months ago it is possible we gave out some early TMLs and made a folder for them - I think maybe there is something old lurking around on your computer that we need to remove manually. If there is a folder can you take a screen grab of the contents for me and I will tell you if you can delete it


Here is a screen shot of the folder location of the macrocommand. One thing i did recently was download the RPS Data Prep Toolbox 1 for the divideline which I did not see any TML in that file.

I dug out the july 2019 training folder and did not see any divideline TML.

issue has been fixed!!!
thank you A.Sharp and RPS Team for the fix.