My Buttons Keep Disappearing - Alienware

This issue comes up periodically with people running Alienware computers from Dell. The computers have an application called Alienware Command Center which when running interferes with the Microsoft technology that is used in TBC for the more recent user interface elements in commands like Vertical Design, on the Start Page and in many of the Rockpile TMLs . The interference can be that it wipes out parts of the dialogs or distorts the text in the dialogs.

The solution to the problem is to disable or deinstall the Alienware Command Center software using Task Manager or Control Panel - Programs and Features and Uninstall the program. From my understanding based on user feedback, deinstalling the program has no adverse effect on the computer operations or performance.

This is an issue that has been recognized by Microsoft as the root cause of these issues, and is a Dell problem to resolve as far as I understand it. The Microsoft Technology to build dialogs and user interface elements is used by millions of software companies worldwide as well as by Trimble and Rockpile Solutions. While it is TBC and Rockpile TMLs that exhibit and expose the problem it is 100% out of our control and there is nothing we can do to resolve it on our side. The only remedy is to deinstall or disable that program from running.

In an earlier post we also found the following to be a potential issue that could also cause the same type of issue, however the problem after more detailed review typically resides with the Alienware Command Center software.

Earlier Post

Today we had a breakthrough with one user that has been having issues with his Buttons and dialog elements disappearing. We found that the issue was a clash between the current setup of his Graphics Drivers and TBCs use of WPF Graphics. In TBC the dialogs have been created in the early days using Windows Forms and more recently dialogs are created using WPF technology. We found that the issue was only affecting those parts of TBC that are using the WPF functionality like the Create Vertical Design command and all of the TML commands and the Start Page of TBC etc.

The resolution was to de-install the Graphics Drivers 100% and then reinstate them from scratch. This has cleared the customer issue and he is now working 100% correctly.

To do the deinstallation of the Graphics Drivers (he had to deinstall both the Intel and Nvidia Drivers from his Dell Machine and reinstate both) he used a tool available from this link - I have not used it personally and cannot say that it will work for all machines in all situations with this problem, but it has solved one persons issue so please try this if you are experiencing similar issues.

Click Here

Thanks to Andy from Riverside Construction for his help and assistance here and his patience in getting this solved. He tested both 5.32 and the upcomingv5.4 and both worked fine.

Awesome - One headache over!